Below is the list of prerequisites for running plugins TBN2NET:

  1. AutoCAD - AutoCAD plugins run in AutoCAD 2007 and higher.  Check if you use the last service pack too!!
  2. AutoCAD LT: requires CADSTA to install plugins in AutoCAD LT
    Some also run on ZWCAD 2017 and 2014+, GstarCAD 2015, BriscsCAD V17 and its superiors
  3. Civil 3D - Plugins that run in Civil 3D Run in Civil 3D 2012 and above. Some run from 2010 and 2011 as well.
  4. Internet Explorer 11
  5. .NET Framework - 3.5 (AutoCAD 2011 and bellow), 4.0 (AutoCAD 2012), 4.5 (autoCAD 2013 to 2017), 4.6 (AutoCAD 2018)
  6. Windows - 7, 8, and 10 , XP and Vista as long as Framework 4.0 is upgraded.

Tip: If you install the TBN2NET plugins, you have installation problems, First check if all the above software is up to date. Then make sure your plugin is up to date. And also check the topic Errors and Solutions